Min Mac OS Version

Post questions and find answers on the latest SpectraLayers release here.
Post Reply
User avatar
madpanic
New Member
Posts: 16
Joined: Thu Jul 02, 2020 3:38 pm
Contact:

Min Mac OS Version

Post by madpanic »

Hi,

I note from the Specs that the Minimum OSX Version is Mojave, so in danger of asking a stupid question, is it likely to work on OSX High Sierra or is that a complete non-starter? It's just that the other Steinberg products like Cubase & Nuendo work on older versions and it seems a bit odd that this product would force you to Upgrade.

Robin Lobel
Moderator
Posts: 375
Joined: Wed Jul 03, 2019 3:39 pm
Contact:

Re: Min Mac OS Version

Post by Robin Lobel »

Officially the minimum macOS version is Mojave (10.14), but you can also install it on High Sierra (10.13). Anything below 10.13 won't work.
You also need a mac with an AVX-capable CPU to fully use all the features (all mac computers after 2010).
Robin Lobel - SpectraLayers creator and lead developer

User avatar
madpanic
New Member
Posts: 16
Joined: Thu Jul 02, 2020 3:38 pm
Contact:

Re: Min Mac OS Version

Post by madpanic »

That's great, thanks Robin. I can't upgrade OSX pass High Siera on my MacPro unless I switch graphics cards, so I'm stuck with High Sierra for now (Upgraded 2009 MacPro to a 2010 equiv).

User avatar
Arionas
Junior Member
Posts: 161
Joined: Tue Oct 27, 2015 10:43 am
Contact:

Re: Min Mac OS Version

Post by Arionas »

madpanic wrote:
Tue Aug 04, 2020 11:02 am
That's great, thanks Robin. I can't upgrade OSX pass High Siera on my MacPro unless I switch graphics cards, so I'm stuck with High Sierra for now (Upgraded 2009 MacPro to a 2010 equiv).
I’m in the same boat. Are our computers AVX-capable?
Cubase Pro 10.5 - Wavelab 10 - Nuendo 4 - Reaper 5 - Pro Tools 12 - Logic X - Harrison Mixbus
Mac Pro 2010, 3.33 x2, 12 cores - High Sierra - RME Fireface 802

Robin Lobel
Moderator
Posts: 375
Joined: Wed Jul 03, 2019 3:39 pm
Contact:

Re: Min Mac OS Version

Post by Robin Lobel »

Unfortunately no. Actions like Heal and Declip may be restricted on your computers. It might be unrestricted with a later SL7 patch.
Robin Lobel - SpectraLayers creator and lead developer

User avatar
Arionas
Junior Member
Posts: 161
Joined: Tue Oct 27, 2015 10:43 am
Contact:

Re: Min Mac OS Version

Post by Arionas »

Robin Lobel wrote:
Wed Aug 05, 2020 12:24 am
Unfortunately no. Actions like Heal and Declip may be restricted on your computers. It might be unrestricted with a later SL7 patch.
Thank you Robin, go for it please!
Cubase Pro 10.5 - Wavelab 10 - Nuendo 4 - Reaper 5 - Pro Tools 12 - Logic X - Harrison Mixbus
Mac Pro 2010, 3.33 x2, 12 cores - High Sierra - RME Fireface 802

User avatar
madpanic
New Member
Posts: 16
Joined: Thu Jul 02, 2020 3:38 pm
Contact:

Re: Min Mac OS Version

Post by madpanic »

Arionas wrote:
Wed Aug 05, 2020 2:36 am
Robin Lobel wrote:
Wed Aug 05, 2020 12:24 am
Unfortunately no. Actions like Heal and Declip may be restricted on your computers. It might be unrestricted with a later SL7 patch.
Thank you Robin, go for it please!
You can check what your Mac supports by opening up a terminal window and running this command:

Code: Select all

sysctl -a | grep machdep.cpu.features | grep AVX
On my mid 2015 Macbook, I get the following:
machdep.cpu.features: FPU VME DE PSE TSC MSR PAE MCE CX8 APIC SEP MTRR PGE MCA CMOV PAT PSE36 CLFSH DS ACPI MMX FXSR SSE SSE2 SS HTT TM PBE SSE3 PCLMULQDQ DTES64 MON DSCPL VMX SMX EST TM2 SSSE3 FMA CX16 TPR PDCM SSE4.1 SSE4.2 x2APIC MOVBE POPCNT AES PCID XSAVE OSXSAVE SEGLIM64 TSCTMR AVX1.0 RDRAND F16C

On my upgraded 2009 MacPro, I get no results :(, so it's not supported.

User avatar
Arionas
Junior Member
Posts: 161
Joined: Tue Oct 27, 2015 10:43 am
Contact:

Re: Min Mac OS Version

Post by Arionas »

madpanic wrote:
Wed Aug 05, 2020 11:23 am
Arionas wrote:
Wed Aug 05, 2020 2:36 am
Robin Lobel wrote:
Wed Aug 05, 2020 12:24 am
Unfortunately no. Actions like Heal and Declip may be restricted on your computers. It might be unrestricted with a later SL7 patch.
Thank you Robin, go for it please!
You can check what your Mac supports by opening up a terminal window and running this command:

Code: Select all

sysctl -a | grep machdep.cpu.features | grep AVX
On my mid 2015 Macbook, I get the following:
machdep.cpu.features: FPU VME DE PSE TSC MSR PAE MCE CX8 APIC SEP MTRR PGE MCA CMOV PAT PSE36 CLFSH DS ACPI MMX FXSR SSE SSE2 SS HTT TM PBE SSE3 PCLMULQDQ DTES64 MON DSCPL VMX SMX EST TM2 SSSE3 FMA CX16 TPR PDCM SSE4.1 SSE4.2 x2APIC MOVBE POPCNT AES PCID XSAVE OSXSAVE SEGLIM64 TSCTMR AVX1.0 RDRAND F16C

On my upgraded 2009 MacPro, I get no results :(, so it's not supported.
Thank you for this information!
Cubase Pro 10.5 - Wavelab 10 - Nuendo 4 - Reaper 5 - Pro Tools 12 - Logic X - Harrison Mixbus
Mac Pro 2010, 3.33 x2, 12 cores - High Sierra - RME Fireface 802

Robin Lobel
Moderator
Posts: 375
Joined: Wed Jul 03, 2019 3:39 pm
Contact:

Re: Min Mac OS Version

Post by Robin Lobel »

Update on this : you can now run SL7 fully even if your CPU doesn't support AVX instructions.
However if you run it on High Sierra, you may experience flickers when displaying VST3 plugins.
Robin Lobel - SpectraLayers creator and lead developer

User avatar
ffg
Member
Posts: 643
Joined: Fri Dec 17, 2010 6:46 pm
Contact:

Re: Min Mac OS Version

Post by ffg »

I'm keen to get SL7 Pro, but I fear the studio computer isn't really suitable - it's a late 2012 MacPro 5.1. I can run High Sierra on it (though I'm usually using Sierra most of the time) and having run the Terminal sequence it appears I don't have AVX. I can open the SL7 pro demo, but it seems glitchy, for example if I run the Noise reduction twice the programme hangs.

Running the same routine on my MacBook Pro (Mohave) works fine.

Having said that, at this early stage I'm very impressed with the Noise Reduction, which was able to entirely remove some nasty mains harmonics from an electric guitar track. Izotope was unable to do this.

Is there any hope that SL7 performance on High Sierra will be better in future?
best wishes

David

I'm going to to let the situation mature...

Nuendo 10.3
Cubase 10.5
MacPro 3.3 6-core OSX 10.12
Macbook Pro OSX 10.14
RME Fireface 802
RME Fireface 800
Audient ID14

Robin Lobel
Moderator
Posts: 375
Joined: Wed Jul 03, 2019 3:39 pm
Contact:

Re: Min Mac OS Version

Post by Robin Lobel »

A late 2012 MacPro 5.1 could probably run SL7 fine, as I'm still doing some tests with a mid 2011 MacMini 5,2.
I'll test your "noise reduction twice" scenario and see if I can repro the issue you're having. If so, something can probably be done about it for the third patch.
Robin Lobel - SpectraLayers creator and lead developer

User avatar
ffg
Member
Posts: 643
Joined: Fri Dec 17, 2010 6:46 pm
Contact:

Re: Min Mac OS Version

Post by ffg »

here's a screenshot of what happened when I ran Noise Reduction twice. I can't close the window.

When you say you're running SL7 on a 2011 Mac Mini, is that with High Sierra? My problem is, I can't upgrade the MacPro to Mohave without fitting a Metal capable graphics card. And even if I do that, I still don't have AVX on the machine (though not sure what difference that will make?)

Thanks for your attention to this, it's much appreciated.
Attachments
SPECTRAL LAYERS 7 NR BUG.jpeg
(329.19 KiB) Not downloaded yet
best wishes

David

I'm going to to let the situation mature...

Nuendo 10.3
Cubase 10.5
MacPro 3.3 6-core OSX 10.12
Macbook Pro OSX 10.14
RME Fireface 802
RME Fireface 800
Audient ID14

Robin Lobel
Moderator
Posts: 375
Joined: Wed Jul 03, 2019 3:39 pm
Contact:

Re: Min Mac OS Version

Post by Robin Lobel »

Thanks for the screenshot, I understand better the issue.
Yes that Mac Mini only supports High Sierra.
I just sent you a new beta installer (check your PM), let me know if you still have the issue with it.
If you still have the issue with that beta installer, please let me know the exact steps to repro the issue.
Robin Lobel - SpectraLayers creator and lead developer

Post Reply

Return to “SpectraLayers 7”

Who is online

Users browsing this forum: No registered users and 1 guest